INSERT INFUSER ASSEMBLY

Machine Model: ecam23.460.s

I assume you are here because you have a Delonghi Coffee Machine displaying the message “Insert Infuser Assembly” and obviously you scratched your head as you have already inserted the infuser assembly. Don’t worry its there. Right for those of you just wanting the fast answer, sorry you need a new control board, well you probably do. Yeah you better read this, I’ll be quick.

Right, I have no access to Delonghi Service Documentation, So I find things out the hard way and have to work out how these machines work by trial and error. So let me tell you what I did and keep in mind some of these steps have solved the issue in the past.

insert infuser assembly

1. I cleaned the transmission to ensure the brew unit (Infuser) cradle can travel freely up and down. in the past this has solved the issue. However in this case, I notice this machine would turn and run the brew unit in the wrong direction until it hit the top micro switch. . So Immediately I was thinking a control issue. I ignored looking at the reed switch that counts the transmission rotations because I assumed the fault related to the very obvious fact the brew unit is going the wrong way. Disclaimer, I have noticed there is some variance to this. Sometimes the brew unit will sit in the down position and sometimes in the brew position while heating. But on a cold start I have observed the micro sends the brew unit to the bottom switch first)

clean coffee grinds from the bottom of the transmission rod, also lube drive rod

2. The board being the main suspect but the transmission motor/motor control board not completely eliminated I put another board in the machine and away we went. The issue resolved accept it wasn’t, as I put the wrong board in as that’s all I had. So now I decided to create Frankenstein. What follows is for all of you thinking I’m gonna repair the board.

3. Ok the board I had some identical to the failed board, the only difference was the micro processor, the brain. So I said why cant I transplant the micro processor from the failed board onto the the good board. And in doing, I will have all the correct software on the good board. Yes I was assuming that when they wronte the software they kept the pin output functionality the same and I was also assuming the fault ws a transistor. Actually I was certain. My theory was the transistor had failed sending the motor the wrong way and thus the encoder counted the wrong number of clicks when it got to the micro switch. Later I can up with a little test for this.

Frankenstein’s Brain Replacement. You can see I did a messy but not a bad job of the transplant.

4. Ok these micro chips, are tiny and difficult to remove but I managed to do it. I had created Frankenstein, I inserted the board back into the machine and did the same bloody thing. The fault had followed the processing chip. Game over. I never expected that. So this insert infuser assembly issue is related to something on the main processor chip. In fact I switch the motor wires around so the motor drove the infuser assembly toward the bottom switch first and it still failed.

Conclusion. in the case of Insert Infuser assembly error. If your infuser is being driven upward first, its likely time to buy a new board. If it goes in the downward in direction and you have cleaned the transmission rod and the error message persists, buy new board.
The main thing is to eliminate other components before you pay for an expensive new board. But I don’t know enough about what the software is doing and what its looking for when it performs its actions. I think this is an issue with a few variables. I’ll open comments if anyone can add more information it would be appreciated.

5 Responses to “INSERT INFUSER ASSEMBLY

  • My DeLonghi Ecam 23460S is doing exactly the same….it has a new “infuser assembly” after the original packed up from an unrelated issue (power failure in the middle of making a cappuccino).

    Also replaced the top micro-switch with a brand new one, which took a month to arrive.

    Also greased all moving parts with machine grease.

    This is an error that reared it’s ugly head over the past couple of years, but after switching it off, and leaving it off for roughly 30mins. it would come back on as normal.

    So having finally received the microswitch, I installed it, and the error cleared, machine working as normal….NOT.

    One cup of coffee this morning, and when I tried to switch the machine back on, the dreaded error returned.

    It seems to clear after I open everything up, and fiddle with the wires, as well as press the chips on the motherboard, in case of chip creep.

    But I am starting to migrate to the opinion that the brain has packed up…..sadly.

    Hope somebody else can give their insights, maybe a simple solution will emerge.

    • Try resetting to factory default before you replace the board.

  • Hello!
    I apologise for my bad English, but I learn it at street.
    If you still have the delonghi ecam problem with mesage “insert infuser assembly” check the bearings of transmission rod. If they are broken and move up and down when you pull and push the rod try to replace them or replace the new transmission rod kit. Fir me is ecxpensive and i replace only the bearings.
    I beleve it will reaolve your problem.
    Greetings!

    • Thanks for your comment. This could be the cause in some cases.

  • I meant the case discribed above. Sorry, I just shared experince.

Leave a Reply

%d bloggers like this: